Unify - Unify Server is down – Incident details
Report an issue
Get updates
Email
API
Report an issue
Get updates
All systems operational
Unify Server is down
Resolved
Major outage
Started 19 days ago
Lasted 2 days
Affected
Unify Minecraft Server
Operational from 9:54 PM to 9:54 PM, Major outage from 9:54 PM to 6:33 PM
Updates
Resolved
27-11-2025 at 18:33:35
Resolved
27-11-2025 at 18:33:35
Unify Minecraft Server is back up. This incident was automatically resolved by Instatus monitoring.
Investigating
25-11-2025 at 21:54:32
Investigating
25-11-2025 at 21:54:32
Unify Minecraft Server is down at the moment. This incident was automatically created by Instatus monitoring.